GL es android vs ios - different outputs issue

Discussion in 'Game Development (Technical)' started by svero, Mar 22, 2012.

  1. svero

    Moderator Original Member Indie Author

    Joined:
    Jul 27, 2004
    Messages:
    3,393
    Likes Received:
    5
    Open GL Es 1.x

    On ios/mac the following...

    glTexEnvfv(GL_TEXTURE_ENV,GL_TEXTURE_ENV_COLOR,aColorArray);
    glTexEnvi(GL_TEXTURE_ENV,GL_TEXTURE_ENV_MODE,GL_BLEND);

    gives me back a solid color for the color passed into glTexEnvf. The same calls
    on android devices are giving me a weird negative image blending of the
    texture color. It almost seems from the docs like the ios stuff is giving the wrong result
    but maybe I'm misreading. Is there a way to get the solid color blended with the alpha consistently. Am I maybe doing something wrong or different on android that's causing the different result. Anyone have a clue about this?
     

Share This Page

  • About Indie Gamer

    When the original Dexterity Forums closed in 2004, Indie Gamer was born and a diverse community has grown out of a passion for creating great games. Here you will find over 10 years of in-depth discussion on game design, the business of game development, and marketing/sales. Indie Gamer also provides a friendly place to meet up with other Developers, Artists, Composers and Writers.
  • Buy us a beer!

    Indie Gamer is delicately held together by a single poor bastard who thankfully gets help from various community volunteers. If you frequent this site or have found value in something you've learned here, help keep the site running by donating a few dollars (for beer of course)!

    Sure, I'll Buy You a Beer